小贝seo

Emlog安装的时候出现"服务器空间php不支持mysql数据库"

php图片
你是否安装过Emlog或者以及安装完成了呢?我相信很多朋友在安装的时候都出现过“服务器空间php不支持mysql数据库”这个错误,下面小贝seo就来讲解一下这是什么错误,是怎样造成的。

报错图

这个提示我刚开始的时候看的我也很懵,本地的mysql数据库跟PHP明明是运行正常的啊,,为什么会报错呢?

我一直都以为是我的模板下载有问题,我尝试了重新下载模板,重新安装,还是不行;然后我又去服务器控制那重装服务器,重新搭建环境,还是不行!

我就开始查资料,原来我的php安装的是7.1版本的,后来我把php降到了5.6版本才提示成功,没想到Emlog对php版本要求的这么严格。

为什么会要求php版本为5.6呢?因为php最好最兼容的就是5.6版本,dedecmsphpcmswordpress 等主流源码都是兼容于5.6版本 现在你懂了吧!



×

感谢您的支持,我们会一直保持!

扫码支持
请土豪扫码随意打赏

打开支付宝扫一扫,即可进行扫码打赏哦

分享从这里开始,精彩与您同在

打赏作者
本博客所有文章如无特别注明均为原创。作者:小贝seo复制或转载请以超链接形式注明转自 小贝seo博客
原文地址《Emlog安装的时候出现"服务器空间php不支持mysql数据库"
分享到:
美工小分队

发表评论

路人甲 表情
Ctrl+Enter快速提交

网友评论(0)